Nova Spektr
Search
K

Operations FAQ

Error: "Please Add The Network You Want To Transact in”
This error occurs when you are trying to sign a transaction for a network which has not yet been added to your Polkadot Vault!
You can use the Novasama Technologies Metadata Portal to find QR codes which will provide your Polkadot Vault Device with the information required to update the chain metadata.
To solve this:
  1. 1.
    Navigate to the metadata portal. Note: This should be done on a device which is not your Polkadot Vault Device.
  2. 2.
    Select the appropriate blockchain that you wish to update the metadata for.
  3. 3.
    If you are updating a chain for the first time, Select the "Chain Specs" tab at the top of the metadata portal screen.
  4. 4.
    Using your Polkadot Vault Device Select "Scan".
  5. 5.
    Scan the Chain Specs QR code with your Polkadot Vault Device.
  6. 6.
    Review the verifier certificate, and Select "Approve" (Parity Signer Device).
  7. 7.
    Select the "Metadata" tab at the top of the metadata portal screen.
  8. 8.
    Using your Polkadot Vault Device Select "Scan".
  9. 9.
    Scan the Metadata QR code with your v Device. Note: this can take a few minutes to complete.
  10. 10.
    Review the verifier certificate and Select "Approve" (Polkadot Vault Device).
Error: "Please Download Network Metadata"
This error occurs when your Polkadot Vault does not have metadata information about the network that you are trying to use.
You can use the Novasama Technologies Metadata Portal to find QR codes which will provide your Polkadot Vault Device with the information required to update the chain metadata.
  1. 1.
    Navigate to the Novasama Technologies Metadata Portal. Note: This should be done on a device which is not your Polkadot Vault Device.
  2. 2.
    Select the appropriate blockchain that you wish to add metadata for.
  3. 3.
    Select the "Metadata" tab at the top of the metadata portal screen.
  4. 4.
    Using your Polkadot Vault Device select "Scanner".
  5. 5.
    Scan the Metadata QR code with your Polkadot Vault Device. Note: this can take a few minutes to complete.
  6. 6.
    Review the verifier certificate and select "Approve" (Polkadot Vault Device).
Error: "Please Update Network Metadata"
This error occurs when your Polkadot Vault has outdated information about the network you are trying to use.
You can use the Novasama Technologies Metadata Portal to find QR codes which will provide your Polkadot Vault Device with the information required to update the chain metadata.
  1. 1.
    Navigate to the metadata portal. Note: This should be done on a device which is not your Polkadot Vault Device.
  2. 2.
    Select the appropriate blockchain that you wish to update the metadata for.
  3. 3.
    Select the "Metadata" tab at the top of the metadata portal screen.
  4. 4.
    Using your Polkadot Vault Device Select "Scan".
  5. 5.
    Scan the Metadata QR code with your Polkadot Vault Device. Note: this can take a few minutes to complete.
  6. 6.
    Review the verifier certificate and Select "Approve" (Polkadot Vault Device).
Error: “Transaction author public key not found.”
This error occurs when your Polkadot Vault doesn’t have a public key associated with the network you’re operating with.
To solve this:
  1. 1.
    Open the Key Set you’re operating with on the Polkadot Vault Device.
  2. 2.
    Tap to Plus at the top right corner of the screen
  3. 3.
    Select the network you’re operating with
  4. 4.
    Enter the derivation path or make it empty if you don’t use derivation
  5. 5.
    Tap Done
  6. 6.
    Confirm that you’ve written down the derivation path and continue
Error: No Permission to Run the Camera – "Please make sure you grant access to camera"
1. Click on the Apple menu and choose System Settings.
2. Choose the Privacy and Security pane.
3. Click Camera.
4. Make sure that the box next to Nova Spektr is checked "on".
5. You may need to restart Nova Spektr for the change to be applied.
Error: "Payload type with code 0xdf is not supported"
You must update your Polkadot Vault to version 6.3.0 or higher in order to use the Dynamic Derivations feature.
Error: "Dynamic derivations not supported yet"
You must update your Polkadot Vault to version 6.3.0 or higher in order to use the Dynamic Derivations feature.